Basic ISIS - LSPDB

This is a brief article which displays the contents of the LSPDB when using IPv4 and IPv6.

First we will configure IPv4 only. This is a simple L1 only, single area topology.

#R1
hostname R1
line con 0
 logging sync
!
router isis
 net 49.0001.0000.0000.0001.00
 is-type level-1
!
int gi1
 ip address 222.222.10.1 255.255.255.0
 ip router isis
 no shut

#R2
hostname R2
line con 0
 logging sync
!
router isis
 net 49.0001.0000.0000.0002.00
 is-type level-1
!
int gi1
 ip address 222.222.10.2 255.255.255.0
 ip router isis
 no shut
!
int gi2
 ip address 222.222.30.2 255.255.255.0
 ip router isis
 isis network point-to-point
 no shut
!
int gi3
 ip address 222.222.20.2 255.255.255.0
 ip router isis
 no shut

#R3
hostname R3
line con 0
 logging sync
!
router isis
 net 49.0001.0000.0000.0003.00
 is-type level-1
!
int gi1
 ip address 222.222.30.3 255.255.255.0
 ip router isis
 isis network point-to-point
 no shut

LSPDB Summary

R1#show isis database 

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime/Rcvd      ATT/P/OL
R1.00-00            * 0x000002E2   0xBC5F                1139/*         0/0/0
R2.00-00              0x0000000A   0x8E66                1165/1199      0/0/0
R2.01-00              0x00000001   0x7CD6                1014/1199      0/0/0
R3.00-00              0x00000004   0xAA25                1165/1199      0/0/0

LSPDB Detail

R1#show isis data detail 

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime/Rcvd      ATT/P/OL
R1.00-00            * 0x000002E2   0xBC5F                1113/*         0/0/0
  Area Address: 49.0001
  NLPID:        0xCC 
  Hostname: R1
  Metric: 10         IS R2.01
  IP Address:   222.222.10.1
  Metric: 10         IP 222.222.10.0 255.255.255.0
R2.00-00              0x0000000A   0x8E66                1139/1199      0/0/0
  Area Address: 49.0001
  NLPID:        0xCC 
  Hostname: R2
  Metric: 10         IS R2.01
  Metric: 10         IS R3.00
  IP Address:   222.222.20.2
  Metric: 10         IP 222.222.10.0 255.255.255.0
  Metric: 10         IP 222.222.30.0 255.255.255.0
  Metric: 10         IP 222.222.20.0 255.255.255.0
R2.01-00              0x00000001   0x7CD6                 987/1199      0/0/0
  Metric: 0          IS R2.00
  Metric: 0          IS R1.00
R3.00-00              0x00000004   0xAA25                1139/1199      0/0/0
  Area Address: 49.0001
  NLPID:        0xCC 
  Hostname: R3
  Metric: 10         IS R2.00
  IP Address:   222.222.30.3
  Metric: 10         IP 222.222.30.0 255.255.255.0

ISIS operates differently than OSPFv2 when it comes to dissementing link-state information. Instead of LSA Types, ISIS uses TLVs. Each TLV is not mentioned in the database output. Instead the total information learned from all TLVs is displayed at once.

The *.01-00 LSPID is only generated by the pseudonode (DIS) for a broadcast domain. This lists the attached routers to the broadcast domain, similar to a Type 2 OSFP LSA.

The *.00-00 LSPIDs are generated by each router. These list attached neighbors and the metric to those neighbors, prefixes attached to the router, IP addresses attached to the router, and the hostname of the router.

Common TLVs

TLVInformationExample

1

Area address(es)

49.0001

2

IS Reachability (Neighbors)

0000.0000.0002.01

137

Hostname

R1

129

Protocols Supported

IPv4

128

IP Internal reachability (prefixes)

222.222.10.0/24

132

Interface addresses

222.222.10.1

232

IPv6 Interface addresses

2001:a:a:10::1

236

IPv6 reachability (prefixes)

2001:a:a:10::/64

IPv6 configuration

#R1
ipv6 unicast-routing
!
router isis
 net 49.0001.0000.0000.0001.00
 address-family ipv6
 is-type level-1
!
int gi1
 no ip address 
 ipv6 address 2001:a:a:10::1/64
 ipv6 router isis

#R2
ipv6 unicast-routing
!
int gi1
 no ip address 
 ipv6 address 2001:a:a:10::2/64
 ipv6 router isis
!
int gi2
 no ip address
 ipv6 address 2001:a:a:30::2/64
 ipv6 router isis
 isis network point-to-point
!
int gi3
 no ip address
 ipv6 address 2001:a:a:20::2/64
 ipv6 router isis

#R3
ipv6 unicast-routing
!
int gi1
 no ip address
 ipv6 address 2001:a:a:30::3/64
 ipv6 router isis
 isis network point-to-point

LSPDB Summary

R1#show isis database 

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime/Rcvd      ATT/P/OL
R1.00-00            * 0x000002E8   0x3190                1049/*         0/0/0
R2.00-00              0x00000014   0xDDCB                1170/1199      0/0/0
R2.01-00              0x00000004   0x76D9                1048/1199      0/0/0
R3.00-00              0x0000000A   0x114C                1170/1199      0/0/0

LSPDB Detail

R1#show isis database detail 

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime/Rcvd      ATT/P/OL
R1.00-00            * 0x000002E8   0x3190                1029/*         0/0/0
  Area Address: 49.0001
  NLPID:        0xCC 0x8E 
  Hostname: R1
  Metric: 10         IS R2.01
  IPv6 Address: 2001:A:A:10::1
  Metric: 10         IPv6 2001:A:A:10::/64
R2.00-00              0x00000014   0xDDCB                1150/1199      0/0/0
  Area Address: 49.0001
  NLPID:        0xCC 0x8E 
  Hostname: R2
  Metric: 10         IS R2.01
  Metric: 10         IS R3.00
  IPv6 Address: 2001:A:A:20::2
  Metric: 10         IPv6 2001:A:A:10::/64
  Metric: 10         IPv6 2001:A:A:30::/64
  Metric: 10         IPv6 2001:A:A:20::/64
R2.01-00              0x00000004   0x76D9                1028/1199      0/0/0
  Metric: 0          IS R2.00
  Metric: 0          IS R1.00
R3.00-00              0x0000000A   0x114C                1150/1199      0/0/0
  Area Address: 49.0001
  NLPID:        0xCC 0x8E 
  Hostname: R3
  Metric: 10         IS R2.00
  IPv6 Address: 2001:A:A:30::3
  Metric: 10         IPv6 2001:A:A:30::/64

The only difference between the database now is that there are IPv6 addresses instead of IPv4 addresses, and there is an additional network layer protocol supported, IPv6 (0x8E) compared to just IPv4 (0xCC) before. Notice that both IPv4 and IPv6 are listed as being supported. IOS-XE by default uses single-topology IPv6, which means that both IPv4 and IPv6 use the same underlying network topology at the same time. This allows for optimization, as two separate topologies are kept (one for IPv4 and one for IPv6). For details, see the Multitopology ISIS article. Also notice that wide metrics are not required to use ISIS for IPv6.

Last updated